$re = '/eventtype="(?<group>administrator)",username="(?<login>.*?)",action="(?<vmid>(?<action>.*?))",object="(?<object>(?<account>.*?))",description="{(?:.*)?,."status":."(?<status>.*)\"}"/m';
$str = '
1597750344,host="api-437dca50.duosecurity.com",eventtype="administrator",username="Billy BA",action="Update User",object="batman",description="{"notes": "Locked keyfob in office and no spare key.", "status": "Bypass"}"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);