import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<meta name=\"csrf-token\" content=\"([^\"]+)\"";
final String string = "<meta content=\"authenticity_token\" name=\"csrf-param\" />\n"
+ "<meta name=\"csrf-token\" content=\"e9c9p1jcvcnt6MQ7v5Pkc98plga8g2dMGX6xC35vwFUS2OY=\" />";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}