// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<meta name="csrf-token" content="([^"]+)""#).unwrap();
let string = "<meta content=\"authenticity_token\" name=\"csrf-param\" />
<meta name=\"csrf-token\" content=\"e9c9p1jcvcnt6MQ7v5Pkc98plga8g2dMGX6xC35vwFUS2OY=\" />";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}