const regex = /<meta name="csrf-token" content="([^"]+)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<meta name="csrf-token" content="([^"]+)"', 'gm')
const str = `<meta content="authenticity_token" name="csrf-param" />
<meta name="csrf-token" content="e9c9p1jcvcnt6MQ7v5Pkc98plga8g2dMGX6xC35vwFUS2OY=" />`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}