const regex = /(?<!\d)\d{1,3}(?:\.\d{1,3}){3},(\d{1,5})(?!\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d)\\d{1,3}(?:\\.\\d{1,3}){3},(\\d{1,5})(?!\\d)', 'gm')
const str = `1.33.3.146,9001,,fwioetwg4utghw4ignc,Fast Running Stable Valid,447,reject,1-65535,0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}