use strict;
my $str = '1.33.3.146,9001,,fwioetwg4utghw4ignc,Fast Running Stable Valid,447,reject,1-65535,0';
my $regex = qr/(?<!\d)\d{1,3}(?:\.\d{1,3}){3},(\d{1,5})(?!\d)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}