use strict;
my $str = 'hello/how/are/you';
my $regex = qr/.*(are.*)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";