#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/songs\/(?!.*\/foo).+"
Local $sString = "/songs/902" & @CRLF & _
"/songs/902/" & @CRLF & _
"/songs/902/bar" & @CRLF & _
"" & @CRLF & _
"/songs/902/foo" & @CRLF & _
"/songs/902/foo/201/bar" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")