re = /^\/songs\/(?!.*\/foo).+/m
str = '/songs/902
/songs/902/
/songs/902/bar
/songs/902/foo
/songs/902/foo/201/bar
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end