using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/songs\/(?!.*\/foo).+";
string input = @"/songs/902
/songs/902/
/songs/902/bar
/songs/902/foo
/songs/902/foo/201/bar
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}