#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{5,6}\/\w{2,4}\/\d{4,6})"
Local $sString = "ADT CASH DEPO00031110 200504/XR/13436" & @CRLF & _
"FNB APP PAYMENT FROM 200505/XR/13587" & @CRLF & _
"INT-BANKING PMT FRM 200505/XR/13554" & @CRLF & _
"FNB APP PAYMENT FROM 292505/PTY/53261" & @CRLF & _
"FNB OB PMT 200505/XR/13541" & @CRLF & _
"INT-BANKING PMT FRM 200505/XR/13537" & @CRLF & _
"FNB APP PAYMENT FROM 200503/PTY/53144" & @CRLF & _
"FNB APP PAYMENT FROM 200430/XR/8810" & @CRLF & _
"SAVERITE 200504/XR/13268"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")