import Foundation
let pattern = #"(\d{5,6}\/\w{2,4}\/\d{4,6})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ADT CASH DEPO00031110 200504/XR/13436
FNB APP PAYMENT FROM 200505/XR/13587
INT-BANKING PMT FRM 200505/XR/13554
FNB APP PAYMENT FROM 292505/PTY/53261
FNB OB PMT 200505/XR/13541
INT-BANKING PMT FRM 200505/XR/13537
FNB APP PAYMENT FROM 200503/PTY/53144
FNB APP PAYMENT FROM 200430/XR/8810
SAVERITE 200504/XR/13268
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)