$re = '/(\d{5,6}\/\w{2,4}\/\d{4,6})/m';
$str = 'ADT CASH DEPO00031110 200504/XR/13436
FNB APP PAYMENT FROM 200505/XR/13587
INT-BANKING PMT FRM 200505/XR/13554
FNB APP PAYMENT FROM 292505/PTY/53261
FNB OB PMT 200505/XR/13541
INT-BANKING PMT FRM 200505/XR/13537
FNB APP PAYMENT FROM 200503/PTY/53144
FNB APP PAYMENT FROM 200430/XR/8810
SAVERITE 200504/XR/13268';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);