#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<base>.+?)(\((?<idx>\d+)\)?)?(?<ext>(\.[\w\.]+))"
Local $sString = "somefile.docx " & @CRLF & _
"somefile" & @CRLF & _
"somefile (6)" & @CRLF & _
"somefile (1).docx" & @CRLF & _
"somefile (2)(1).docx" & @CRLF & _
"somefile (4).htm.tmpl"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")