re = /(?<base>.+?)(\((?<idx>\d+)\)?)?(?<ext>(\.[\w\.]+))/m
str = 'somefile.docx
somefile
somefile (6)
somefile (1).docx
somefile (2)(1).docx
somefile (4).htm.tmpl'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end