package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)((([A-Za-z]{3,9}:(?:\/\/)?)(?:[-;:&=\+\$,\w]+@)?[A-Za-z0-9.-]+|(?:www.|[-;:&=\+\$,\w]+@)[A-Za-z0-9.-]+)((?:\/[\+~%\/.\w\-_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[.\!\/\\w]*))?)`)
var str = `The google search url www.google.com that we all used to love.
http://www.google.com is same as above except with the http protocol.
This of course a hyperlink to an email mailto:somebody@google.com
Someone's email address somebody@google.com
This is a web address www.url-with-querystring.com/?url=has-querystring&url-2=anotherstring ends with a query strings.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}