import re
regex = re.compile(r"((([A-Za-z]{3,9}:(?:\/\/)?)(?:[-;:&=\+\$,\w]+@)?[A-Za-z0-9.-]+|(?:www.|[-;:&=\+\$,\w]+@)[A-Za-z0-9.-]+)((?:\/[\+~%\/.\w\-_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[.\!\/\\w]*))?)", flags=re.IGNORECASE)
test_str = ("The google search url www.google.com that we all used to love.\n"
"http://www.google.com is same as above except with the http protocol.\n"
"This of course a hyperlink to an email mailto:somebody@google.com\n"
"Someone's email address somebody@google.com\n"
"This is a web address www.url-with-querystring.com/?url=has-querystring&url-2=anotherstring ends with a query strings.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")