// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)((([A-Za-z]{3,9}:(?:\/\/)?)(?:[-;:&=\+\$,\w]+@)?[A-Za-z0-9.-]+|(?:www.|[-;:&=\+\$,\w]+@)[A-Za-z0-9.-]+)((?:\/[\+~%\/.\w\-_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[.\!\/\\w]*))?)").unwrap();
let string = "The google search url www.google.com that we all used to love.
http://www.google.com is same as above except with the http protocol.
This of course a hyperlink to an email mailto:somebody@google.com
Someone's email address somebody@google.com
This is a web address www.url-with-querystring.com/?url=has-querystring&url-2=anotherstring ends with a query strings.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}