#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i) *\b(?=[a-z\d]*([a-z\d])\1{3}|\d+\b)[a-z\d]+"
Local $sString = "df" & @CRLF & _
"All aaaaaab the best 8965" & @CRLF & _
"US issssss is 123 good " & @CRLF & _
"qqqq qwerty 1 poiks" & @CRLF & _
"lkjh ggggqwe 1234 aqwe iphone5224s"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)