# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r" *\b(?=[a-z\d]*([a-z\d])\1{3}|\d+\b)[a-z\d]+"
test_str = ("df\n"
"All aaaaaab the best 8965\n"
"US issssss is 123 good \n"
"qqqq qwerty 1 poiks\n"
"lkjh ggggqwe 1234 aqwe iphone5224s")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.