re = / *\b(?=[a-z\d]*([a-z\d])\1{3}|\d+\b)[a-z\d]+/i
str = 'df
All aaaaaab the best 8965
US issssss is 123 good
qqqq qwerty 1 poiks
lkjh ggggqwe 1234 aqwe iphone5224s'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result