using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(A[ABEHKLMPRSTWXY]|B[ABEHKLMT]|C[ABCEHKLR])[0-9]{6}$";
string input = @"AB123456
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}