package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(A[ABEHKLMPRSTWXY]|B[ABEHKLMT]|C[ABCEHKLR])[0-9]{6}$`)
var str = `AB123456
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}