$re = '/^(A[ABEHKLMPRSTWXY]|B[ABEHKLMT]|C[ABCEHKLR])[0-9]{6}$/';
$str = 'AB123456
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);