import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*px\\;)([ \\S]*)";
final String string = ".inpt-line {\n"
+ " position: relative;\n"
+ " display: block;\n"
+ " min-height: 56px;\n"
+ " width: 660px;\n"
+ " box-sizing: border-box;\n"
+ " padding: 20px 20px 5px 20px;\n"
+ " color: #787373;\n"
+ "}\n\n"
+ ".inpt-line label {\n"
+ " font-size: 22px;\n"
+ " font-weight: bold;\n"
+ " text-align: right;\n"
+ " width: 250px;\n"
+ " height: 50px; \n"
+ "}\n\n"
+ ".inpt-line input,\n"
+ ".inpt-line select {\n"
+ " position: relative;\n"
+ " top: -3px;\n"
+ " height: 30px;\n"
+ " width: 235px;\n"
+ " font-size: 18px;\n"
+ " padding-left: 10px;\n"
+ " box-sizing: border-box;\n"
+ " margin: 0px 15px 5px 10px;\n"
+ "}\n\n"
+ "input[type=\"number\"] {\n"
+ " width: 80px\n"
+ "}\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}