const regex = /(?:^|[^"'])(\b(https?|ftp|file):\/\/[-a-zA-Z0-9+&@#\/%?=~_|!:,.;]*(?:png|jpeg|jpg|gif|bmp))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|[^"\'])(\\b(https?|ftp|file):\\\/\\\/[-a-zA-Z0-9+&@#\\\/%?=~_|!:,.;]*(?:png|jpeg|jpg|gif|bmp))', 'g')
const str = `some image http://cdn.sstatic.net/stackoverflow/img/sprites.png?v=6
some image <img src="http://cdn.sstatic.net/stackoverflow/img/sprites.png?v=6">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}