re = /(?:^|[^"'])(\b(https?|ftp|file):\/\/[-a-zA-Z0-9+&@#\/%?=~_|!:,.;]*(?:png|jpeg|jpg|gif|bmp))/
str = 'some image http://cdn.sstatic.net/stackoverflow/img/sprites.png?v=6
some image <img src="http://cdn.sstatic.net/stackoverflow/img/sprites.png?v=6">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end