$re = '/(?:^|[^"\'])(\b(https?|ftp|file):\/\/[-a-zA-Z0-9+&@#\/%?=~_|!:,.;]*(?:png|jpeg|jpg|gif|bmp))/';
$str = 'some image http://cdn.sstatic.net/stackoverflow/img/sprites.png?v=6
some image <img src="http://cdn.sstatic.net/stackoverflow/img/sprites.png?v=6">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);