$re = '/.*\\\\([^\\\\]+)\\\\/m';
$str = 'G:\\DATA1\\DATA2\\DATA3\\DATA4\\my target\\file.xxx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);