re = /.*\\([^\\]+)\\/m
str = 'G:\\DATA1\\DATA2\\DATA3\\DATA4\\my target\\file.xxx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end