#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)^ # Start of line" & @CRLF & _
" (?! # Start of the alternation group" & @CRLF & _
" (?=.*\d)(?=.*[a-z])(?=.*[A-Z]) # Conditions 1, 2, 3" & @CRLF & _
" |" & @CRLF & _
" (?=.*\d)(?=.*[a-z])(?=.*[!@#$%^&*()_+]) # Conditions 1, 2, 4" & @CRLF & _
" |" & @CRLF & _
" (?=.*\d)(?=.*[A-Z])(?=.*[!@#$%^&*()_+]) # Conditions 1, 3, 4" & @CRLF & _
" | " & @CRLF & _
" (?=.*[a-z])(?=.*[A-Z])(?=.*[!@#$%^&*()_+]) # Conditions 2, 3, 4" & @CRLF & _
" | " & @CRLF & _
" (?=.*[a-z])(?=.*[A-Z])(?=.*[!@#$%^&*()_+]) # Conditions 1, 3, 4" & @CRLF & _
" )" & @CRLF & _
" .* # The line itself is matched" & @CRLF & _
"$ # Up to the end of line"
Local $sString = "12345678" & @CRLF & _
"adfghj" & @CRLF & _
"AASDFGHJ" & @CRLF & _
"!@#$%^&" & @CRLF & _
"1234as" & @CRLF & _
"1234ASDF" & @CRLF & _
"1345!#$%" & @CRLF & _
"asdfg!@#$" & @CRLF & _
"ASDFGB!#$$" & @CRLF & _
"SSRasd" & @CRLF & _
"Goodone123" & @CRLF & _
"G00done!@#" & @CRLF & _
"1@a" & @CRLF & _
"Aa1" & @CRLF & _
"" & @CRLF & _
"must have 3 of 4:" & @CRLF & _
"Contain Numbers" & @CRLF & _
"Contain a-z" & @CRLF & _
"Contain A-Z" & @CRLF & _
"contain special characters !@#$%^&*()_+" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")