import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ # Start of line\n"
+ " (?! # Start of the alternation group\n"
+ " (?=.*\\d)(?=.*[a-z])(?=.*[A-Z]) # Conditions 1, 2, 3\n"
+ " |\n"
+ " (?=.*\\d)(?=.*[a-z])(?=.*[!@#$%^&*()_+]) # Conditions 1, 2, 4\n"
+ " |\n"
+ " (?=.*\\d)(?=.*[A-Z])(?=.*[!@#$%^&*()_+]) # Conditions 1, 3, 4\n"
+ " | \n"
+ " (?=.*[a-z])(?=.*[A-Z])(?=.*[!@#$%^&*()_+]) # Conditions 2, 3, 4\n"
+ " | \n"
+ " (?=.*[a-z])(?=.*[A-Z])(?=.*[!@#$%^&*()_+]) # Conditions 1, 3, 4\n"
+ " )\n"
+ " .* # The line itself is matched\n"
+ "$ # Up to the end of line";
final String string = "12345678\n"
+ "adfghj\n"
+ "AASDFGHJ\n"
+ "!@#$%^&\n"
+ "1234as\n"
+ "1234ASDF\n"
+ "1345!#$%\n"
+ "asdfg!@#$\n"
+ "ASDFGB!#$$\n"
+ "SSRasd\n"
+ "Goodone123\n"
+ "G00done!@#\n"
+ "1@a\n"
+ "Aa1\n\n"
+ "must have 3 of 4:\n"
+ "Contain Numbers\n"
+ "Contain a-z\n"
+ "Contain A-Z\n"
+ "contain special characters !@#$%^&*()_+\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}