# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^ # Start of line
(?! # Start of the alternation group
(?=.*\d)(?=.*[a-z])(?=.*[A-Z]) # Conditions 1, 2, 3
|
(?=.*\d)(?=.*[a-z])(?=.*[!@#$%^&*()_+]) # Conditions 1, 2, 4
|
(?=.*\d)(?=.*[A-Z])(?=.*[!@#$%^&*()_+]) # Conditions 1, 3, 4
|
(?=.*[a-z])(?=.*[A-Z])(?=.*[!@#$%^&*()_+]) # Conditions 2, 3, 4
|
(?=.*[a-z])(?=.*[A-Z])(?=.*[!@#$%^&*()_+]) # Conditions 1, 3, 4
)
.* # The line itself is matched
$ # Up to the end of line
"""
test_str = ("12345678\n"
"adfghj\n"
"AASDFGHJ\n"
"!@#$%^&\n"
"1234as\n"
"1234ASDF\n"
"1345!#$%\n"
"asdfg!@#$\n"
"ASDFGB!#$$\n"
"SSRasd\n"
"Goodone123\n"
"G00done!@#\n"
"1@a\n"
"Aa1\n\n"
"must have 3 of 4:\n"
"Contain Numbers\n"
"Contain a-z\n"
"Contain A-Z\n"
"contain special characters !@#$%^&*()_+\n")
matches = re.finditer(regex, test_str, re.VERBOSE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.