using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]+(\.[0-9]?)\/[0-9]+(\.[0-9]?)";
string input = @"1000/23232
100.1/2323
100.6/2323443.6
100.00
99.99
0/
01.23
1.23
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}