use strict;
my $str = '1000/23232
100.1/2323
100.6/2323443.6
100.00
99.99
0/
01.23
1.23
';
my $regex = qr/[0-9]+(\.[0-9]?)\/[0-9]+(\.[0-9]?)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}