$re = '/[0-9]+(\.[0-9]?)\/[0-9]+(\.[0-9]?)/m';
$str = '1000/23232
100.1/2323
100.6/2323443.6
100.00
99.99
0/
01.23
1.23
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);