package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^a-zA-Z.]+`)
var str = `H''''i i""m Bob. I go--to--School and I_Like to Code.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}