$re = '~[^a-zA-Z.]+~m';
$str = 'H\'\'\'\'i i""m Bob. I go--to--School and I_Like to Code.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);