re = /[^a-zA-Z.]+/m
str = 'H\'\'\'\'i i""m Bob. I go--to--School and I_Like to Code.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end