import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.(?i:engine|inc|install|make|module|profile|po|sh|.*sql|theme|twig|tpl(\\.php)?|xtmpl|yml|sw[op]|bak|orig|save|lock)$|^composer\\.json$|^#.*#$|~$";
final String string = ".engine\n"
+ ".inc\n"
+ ".install\n"
+ ".make\n"
+ ".module\n"
+ ".module~\n"
+ ".module.bak\n"
+ ".module.orig\n"
+ ".module.save\n"
+ ".module.swo\n"
+ ".module.swp\n"
+ ".php~\n"
+ ".php.bak\n"
+ ".php.orig\n"
+ ".php.save\n"
+ ".php.swo\n"
+ ".php.swp\n"
+ ".profile\n"
+ ".po\n"
+ ".sh\n"
+ ".sql\n"
+ ".theme\n"
+ ".twig\n"
+ ".tpl.php\n"
+ ".xtmpl\n"
+ ".yml";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}