const regex = /\.(?i:engine|inc|install|make|module|profile|po|sh|.*sql|theme|twig|tpl(\.php)?|xtmpl|yml|sw[op]|bak|orig|save|lock)$|^composer\.json$|^#.*#$|~$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(?i:engine|inc|install|make|module|profile|po|sh|.*sql|theme|twig|tpl(\\.php)?|xtmpl|yml|sw[op]|bak|orig|save|lock)$|^composer\\.json$|^#.*#$|~$', 'gm')
const str = `.engine
.inc
.install
.make
.module
.module~
.module.bak
.module.orig
.module.save
.module.swo
.module.swp
.php~
.php.bak
.php.orig
.php.save
.php.swo
.php.swp
.profile
.po
.sh
.sql
.theme
.twig
.tpl.php
.xtmpl
.yml`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}