import Foundation
let pattern = ##"\.(?i:engine|inc|install|make|module|profile|po|sh|.*sql|theme|twig|tpl(\.php)?|xtmpl|yml|sw[op]|bak|orig|save|lock)$|^composer\.json$|^#.*#$|~$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
.engine
.inc
.install
.make
.module
.module~
.module.bak
.module.orig
.module.save
.module.swo
.module.swp
.php~
.php.bak
.php.orig
.php.save
.php.swo
.php.swp
.profile
.po
.sh
.sql
.theme
.twig
.tpl.php
.xtmpl
.yml
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)