import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<=county\\s)|(?<=co\\s)|(?<=co\\.))(?P<county>[a-z]{4,})|(?P<county2>[a-z]{4,})(?=\\scounty)";
final String string = "ddd easd fasdf county london\n"
+ "ABCD XYZ County Herefordshire or Co.Kent or London County";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}