re = /((?<=county\s)|(?<=co\s)|(?<=co\.))(?P<county>[a-z]{4,})|(?P<county2>[a-z]{4,})(?=\scounty)/i
str = 'ddd easd fasdf county london
ABCD XYZ County Herefordshire or Co.Kent or London County'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end