$re = '/((?<=county\s)|(?<=co\s)|(?<=co\.))(?P<county>[a-z]{4,})|(?P<county2>[a-z]{4,})(?=\scounty)/i';
$str = 'ddd easd fasdf county london
ABCD XYZ County Herefordshire or Co.Kent or London County';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);