using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:https?:\/\/)?(?:www\.)?(?:gettyimages|gty)\.(?:\w+)\/(?:license|detail|detail\/photo\/(?:\w|\-)+)\/((?:\-|\w)+)(?:\w|&|=|\?)*";
string input = @"http://www.gettyimages.com/license/182149877?share=site_twitter&plapla=asdasd&plfsdfapla=asdafdssd&plaasdpla=asdafsdsd fd
";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}