$re = '/(?:https?:\/\/)?(?:www\.)?(?:gettyimages|gty)\.(?:\w+)\/(?:license|detail|detail\/photo\/(?:\w|\-)+)\/((?:\-|\w)+)(?:\w|&|=|\?)*/i';
$str = 'http://www.gettyimages.com/license/182149877?share=site_twitter&plapla=asdasd&plfsdfapla=asdafdssd&plaasdpla=asdafsdsd fd
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);