import re
regex = re.compile(r"(?:https?:\/\/)?(?:www\.)?(?:gettyimages|gty)\.(?:\w+)\/(?:license|detail|detail\/photo\/(?:\w|\-)+)\/((?:\-|\w)+)(?:\w|&|=|\?)*", flags=re.IGNORECASE)
test_str = ("http://www.gettyimages.com/license/182149877?share=site_twitter&plapla=asdasd&plfsdfapla=asdafdssd&plaasdpla=asdafsdsd fd\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")