$re = '/(?(?=.* .*)(?:([^ \n>]*)(?:.*))|([^\w\W]))/m';
$str = '"SWN-WZ-SB00-49-03-C11>> bla"
"SWN-WZ-SB00-49-03-C11 >> "
"SWN-WZ-SB00-49-03-C11 >>"
"SWN-WZ-SB00-49-03-C11 >> bla"
"SWN-WZ-SB00-49-03-C11>>"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);