re = /(?(?=.* .*)(?:([^ \n>]*)(?:.*))|([^\w\W]))/m
str = '"SWN-WZ-SB00-49-03-C11>> bla"
"SWN-WZ-SB00-49-03-C11 >> "
"SWN-WZ-SB00-49-03-C11 >>"
"SWN-WZ-SB00-49-03-C11 >> bla"
"SWN-WZ-SB00-49-03-C11>>"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end